FabricationSaveJobOptions Class

Options for FabricationPart.SaveAsFabricationJob() method.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.FabricationFabricationSaveJobOptions

Namespace: Autodesk.Revit.DB.Fabrication
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FabricationSaveJobOptions : IDisposable

The FabricationSaveJobOptions type exposes the following members.

Constructors
 NameDescription
Public methodFabricationSaveJobOptions Default Constructor
Public methodFabricationSaveJobOptions(Boolean) Constructor
Top
Properties
 NameDescription
Public propertyAddHolesForTaps Set true to have holes for taps on straights added to the created fabrication job.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the FabricationSaveJobOptions
Top
See Also