EnergyAnalysisSurfaceCADLinkUniqueId Property |
The unique id of the originating CAD object's link (linked document) associated with this surface.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic string CADLinkUniqueId { get; }
Public ReadOnly Property CADLinkUniqueId As String
Get
public:
property String^ CADLinkUniqueId {
String^ get ();
}
member CADLinkUniqueId : string with get
Property Value
String
Remarks
This id can be passed to obtain the element from Document.Element[string] property, but any link obtained through this method
may no longer be a valid or up-to-date link. The originating CAD link is only accurate and up-to-date at the time of creation of the energy model.
An empty string is returned if the originating CAD object is not hosted in a linked document.
See Also