DocumentExport(String, String, ViewSet, DWFExportOptions) Method |
Exports the current view or a selection of views in DWF format.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool Export(
string folder,
string name,
ViewSet views,
DWFExportOptions options
)
Public Function Export (
folder As String,
name As String,
views As ViewSet,
options As DWFExportOptions
) As Boolean
public:
bool Export(
String^ folder,
String^ name,
ViewSet^ views,
DWFExportOptions^ options
)
member Export :
folder : string *
name : string *
views : ViewSet *
options : DWFExportOptions -> bool
Parameters
- folder String
- Output folder, into which file(s) will be exported. The folder must exist.
- name String
- Either the name of a single file or a prefix for a set of files.
If or empty, automatic naming will be used.
- views ViewSet
- Selection of views to be exported.
- options DWFExportOptions
- Various options applicable to the DWF format.
If , all options will be set to their respective default values.
Return Value
BooleanFunction returns true only if all specified views are exported successfully. Returns False if exporting of any view fails,
even if some views might have been exported successfully.
Exceptions
RemarksAll the views must be printable in order for the Export to succeed.
It can be assured by checking the CanBePrinted property of each view.
Examplepublic bool ExportViewToDWF(Document document, View view, string pathname)
{
DWFExportOptions dwfOptions = new DWFExportOptions();
dwfOptions.CropBoxVisible = true;
dwfOptions.ExportingAreas = true;
dwfOptions.ExportTexture = false;
ViewSet views = new ViewSet();
views.Insert(view);
return (document.Export(Path.GetDirectoryName(pathname),
Path.GetFileNameWithoutExtension(pathname), views, dwfOptions));
}
Public Function ExportViewToDWF(document As Document, view As View, pathname As String) As Boolean
Dim dwfOptions As New DWFExportOptions()
dwfOptions.CropBoxVisible = True
dwfOptions.ExportingAreas = True
dwfOptions.ExportTexture = False
Dim views As New ViewSet()
views.Insert(view)
Return (document.Export(Path.GetDirectoryName(pathname), Path.GetFileNameWithoutExtension(pathname), views, dwfOptions))
End Function
No code example is currently available or this language may not be supported.
No code example is currently available or this language may not be supported.
See Also