DocumentExport(String, String, OBJExportOptions) Method |
Exports a view specified in the export options to the OBJ format.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool Export(
string folder,
string name,
OBJExportOptions options
)
Public Function Export (
folder As String,
name As String,
options As OBJExportOptions
) As Boolean
public:
bool Export(
String^ folder,
String^ name,
OBJExportOptions^ options
)
member Export :
folder : string *
name : string *
options : OBJExportOptions -> bool
Parameters
- folder String
-
Output folder into which the file will be exported. The folder must exist.
- name String
-
Indicates the name of the OBJ file to export. If it doesn't end with ".obj", this extension will be added automatically.
The name cannot contain any of the following characters: \/:*?"<>|. Empty name is not acceptable.
- options OBJExportOptions
-
Various options applicable to the OBJ format.
Return Value
Boolean
True if successful, otherwise False.
Exceptions
See Also