ViewScheduleSplitSegment Method |
Splits the schedule segment by the given heights of new segments.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SplitSegment(
int segmentIndex,
IList<double> segmentHeights
)
Public Sub SplitSegment (
segmentIndex As Integer,
segmentHeights As IList(Of Double)
)
public:
void SplitSegment(
int segmentIndex,
IList<double>^ segmentHeights
)
member SplitSegment :
segmentIndex : int *
segmentHeights : IList<float> -> unit
Parameters
- segmentIndex Int32
-
The index of segment, starting with 0.
- segmentHeights IListDouble
-
An array contains the height for each new segment except the last segment.
The height of the last segment will be determined by the height of previous new segments and the height of the split segment.
ExceptionsException | Condition |
---|
ArgumentException |
The height of a schedule segment must be greater than 0. The total height must be less than the split segment height.
The total segment count must be greater than 0 and less than 10000.
-or-
The segment index should start from 0 and be less than the total segment count.
|
ArgumentNullException |
A non-optional argument was null
|
InvalidOperationException |
This ViewSchedule is not split yet.
|
Remarks
The height values are used to set the height of schedule instance for each segment shown on sheet view.
Each input height must be greater than 0 and the total height must be less than the height of the split segment.
See Also