TransactionSetFailureHandlingOptions Method |
Sets options for handling failures to be used when the transaction is being committed or rolled back.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetFailureHandlingOptions(
FailureHandlingOptions options
)
Public Sub SetFailureHandlingOptions (
options As FailureHandlingOptions
)
public:
void SetFailureHandlingOptions(
FailureHandlingOptions^ options
)
member SetFailureHandlingOptions :
options : FailureHandlingOptions -> unit
Parameters
- options FailureHandlingOptions
-
An instance of FailureHandlingOptions to be applied to the transaction
Exceptions
Remarks
Options can be set at any time before the transaction is either committed or rolled back.
See
FailureHandlingOptions for details about available options.
Once committed or rolled back, the transaction object will reset its options to their default values.
Example
using (Transaction transaction = new Transaction(doc))
{
transaction.Start("Creating room");
FailureHandlingOptions options = transaction.GetFailureHandlingOptions();
options.SetFailuresPreprocessor(new RoomWarningSwallower());
transaction.SetFailureHandlingOptions(options);
if (null != doc.Create.NewRoom(level, UV.Zero))
{
transaction.Commit();
}
else
{
transaction.RollBack();
}
}
Using transaction As New Transaction(doc)
transaction.Start("Creating room")
Dim options As FailureHandlingOptions = transaction.GetFailureHandlingOptions()
options.SetFailuresPreprocessor(New RoomWarningSwallower())
transaction.SetFailureHandlingOptions(options)
If doc.Create.NewRoom(level, UV.Zero) IsNot Nothing Then
transaction.Commit()
Else
transaction.RollBack()
End If
End Using
No code example is currently available or this language may not be supported.
No code example is currently available or this language may not be supported.
See Also