PipeScheduleTypeCreate Method |
Creates a new pipe schedule type with the given name.
Namespace: Autodesk.Revit.DB.PlumbingAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static PipeScheduleType Create(
Document doc,
string name
)
Public Shared Function Create (
doc As Document,
name As String
) As PipeScheduleType
public:
static PipeScheduleType^ Create(
Document^ doc,
String^ name
)
static member Create :
doc : Document *
name : string -> PipeScheduleType
Parameters
- doc Document
-
The document
- name String
-
The name of requested schedule type.
Return Value
PipeScheduleType
Returns the newly created schedule type.
Exceptions
Remarks
If the name is already taken by an existing schedule type, an InvalidOperationException will be thrown.
See Also