IFrameworkElementCreator Interface |
Interface that the Revit UI will call, if present, to construct the FrameworkElement
for the pane.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic interface IFrameworkElementCreator
Public Interface IFrameworkElementCreator
public interface class IFrameworkElementCreator
type IFrameworkElementCreator = interface end
The IFrameworkElementCreator type exposes the following members.
Methods
Example
internal class BrowserCreator : IFrameworkElementCreator
{
public FrameworkElement CreateFrameworkElement()
{
return new WebBrowser();
}
}
Friend Class BrowserCreator
Implements IFrameworkElementCreator
Public Function CreateFrameworkElement() As FrameworkElement Implements IFrameworkElementCreator.CreateFrameworkElement
Return New WebBrowser()
End Function
End Class
No code example is currently available or this language may not be supported.
No code example is currently available or this language may not be supported.
See Also