CompoundStructureGetSegmentIds Method |
Gets the segment ids of this compound structure.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IList<int> GetSegmentIds()
Public Function GetSegmentIds As IList(Of Integer)
public:
IList<int>^ GetSegmentIds()
member GetSegmentIds : unit -> IList<int>
Return Value
IListInt32
The ids of the segments which form the boundary of the regions of this CompoundStructure.
Exceptions
Remarks
The boundaries of the regions of a vertically compound structure consist of vertical
horizontal segments with unique ids.
See Also