CategoryCategoryType Property |
Gets the category type of this category.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic CategoryType CategoryType { get; }
Public ReadOnly Property CategoryType As CategoryType
Get
public:
property CategoryType CategoryType {
CategoryType get ();
}
member CategoryType : CategoryType with get
Property Value
CategoryType
Remarks
The category type determines if the category is shown in the Visibility/Graphics settings
grouped with the model,annotation, or analytical model categories.
Note that import categories are also "model" but will be shown separately in the dialog.
Some categories not shown in the dialog and will return Internal for the category type.
See Also