TextElementText Property

The content of the element as a plain string stripped of all formating.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public string Text { get; set; }

Property Value

String
Exceptions
ExceptionCondition
ArgumentNullException When setting this property: A non-optional argument was null
Remarks

If a new text content is set, all previous formating that might have been set on parts of the original text will be lost. After setting the new text, only the formating parameters of the associated text type will be applied.

The value of this property can also be accessed via the TEXT_TEXT Built-In parameter.

See Also