StairsEditScope Constructor |
Instantiates a StairsEditScope object.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic StairsEditScope(
Document document,
string transactionName
)
Public Sub New (
document As Document,
transactionName As String
)
public:
StairsEditScope(
Document^ document,
String^ transactionName
)
new :
document : Document *
transactionName : string -> StairsEditScope
Parameters
- document Document
-
The document for which this StairsEditScope is going to be used.
- transactionName String
-
The name that will appear in the Undo menu in Revit after the StairsEditScope is successfully committed.
ExceptionsException | Condition |
---|
ArgumentException |
document is not a primary document, it is a linked document.
-or-
document is not a project document.
-or-
transactionName is an empty string.
|
ArgumentNullException |
A non-optional argument was null
|
See Also