ViewGetWorksetVisibility Method

Returns the visibility settings of a workset for this particular view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public WorksetVisibility GetWorksetVisibility(
	WorksetId worksetId
)

Parameters

worksetId  WorksetId
Id of the workset.

Return Value

WorksetVisibility
The visibility of a workset for this particular view.
Exceptions
ExceptionCondition
ArgumentException There is no workset with this Id in the document associated with this view.
ArgumentNullException A non-optional argument was null
Remarks
The settings does not reflect the fact of whether a workset is currently closed or not.
See Also