Loads or reloads the link from its currently-stored location. If the link is an
external resource, Revit will contact the IExternalResourceServer to get the latest version
of the link.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic LinkLoadResult Reload()
Public Function Reload As LinkLoadResult
public:
LinkLoadResult^ Reload()
member Reload : unit -> LinkLoadResult
Return Value
LinkLoadResult
An object containing the ElementId of the link
and an enum value indicating any
errors which occurred while trying to load.
ExceptionsException | Condition |
---|
InvalidOperationException |
This CADLinkType represents an import and cannot be used as a link.
-or-
The element "this CADLinkType" is in a read-only document.
|
RemarksIf the link is currently loaded, any changes made in-memory
to the link's shared coordinates will be discarded.
Graphic overrides will be preserved on reload.
If the original view used to bring in this link has
been deleted, Revit will cancel the load.
See Also