RebarConstraintsManagerAllowConstraintTargets Method |
Returns true if references are valid targets for handle, false otherwise.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool AllowConstraintTargets(
RebarConstrainedHandle handle,
IList<Reference> targetsToConstrain
)
Public Function AllowConstraintTargets (
handle As RebarConstrainedHandle,
targetsToConstrain As IList(Of Reference)
) As Boolean
public:
bool AllowConstraintTargets(
RebarConstrainedHandle^ handle,
IList<Reference^>^ targetsToConstrain
)
member AllowConstraintTargets :
handle : RebarConstrainedHandle *
targetsToConstrain : IList<Reference> -> bool
Parameters
- handle RebarConstrainedHandle
-
Represents the constrainable rebar handle.
- targetsToConstrain IListReference
-
Represent the refernces to be checked as valid targets for handle.
Return Value
Boolean
Exceptions
RemarksFor a free form rebar valid targets are one or more references to faces of elements that can host rebar.
For a shape driven rebar this function will always return false. RebarConstraintsManager.GetConstraintCandidatesForHandle() can be used to obtain possible constraints.
See Also