StructuralConnectionHandlerTypeIsTypeNameValidForCustomConnection Method |
Validates if the input name matches the criteria of StructuralConnectionHandlerType name.
Name must be unique among other existing StructuralConnectionHandlerTypes and cannot contain any of the following characters: new line, {}[];`~\\/:*?";<>| or any of the non-printable characters.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool IsTypeNameValidForCustomConnection(
Document document,
string typeName
)
Public Shared Function IsTypeNameValidForCustomConnection (
document As Document,
typeName As String
) As Boolean
public:
static bool IsTypeNameValidForCustomConnection(
Document^ document,
String^ typeName
)
static member IsTypeNameValidForCustomConnection :
document : Document *
typeName : string -> bool
Parameters
- document Document
-
The Document.
- typeName String
-
The StructuralConnectionHandlerType name to validate.
Return Value
Boolean
True if the input name matches the criteria of StructuralConnectionHandlerType name.
Exceptions
See Also