DeleteWorksetSettings Class

This class represents the settings used to delete a workset.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBDeleteWorksetSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class DeleteWorksetSettings : IDisposable

The DeleteWorksetSettings type exposes the following members.

Constructors
 NameDescription
Public methodDeleteWorksetSettings Constructs a DeleteWorksetSettings object with DeleteWorksetOption::DeleteAllElements option.
Public methodDeleteWorksetSettings(DeleteWorksetOption, WorksetId) Constructs a DeleteWorksetSettings object.
Top
Properties
 NameDescription
Public propertyDeleteWorksetOption The current delete workset option.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyWorksetId The target worksetId for those elements under the deleted workset, which is used for DeleteWorksetOption::MoveElementsToWorkset.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the DeleteWorksetSettings
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also