DirectShapeAddReferencePoint(XYZ, DirectShapeReferenceOptions) Method |
Adds a reference point to the DirectShape.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void AddReferencePoint(
XYZ refPoint,
DirectShapeReferenceOptions options
)
Public Sub AddReferencePoint (
refPoint As XYZ,
options As DirectShapeReferenceOptions
)
public:
void AddReferencePoint(
XYZ^ refPoint,
DirectShapeReferenceOptions^ options
)
member AddReferencePoint :
refPoint : XYZ *
options : DirectShapeReferenceOptions -> unit
Parameters
- refPoint XYZ
-
The coordinates of the new reference point.
- options DirectShapeReferenceOptions
-
The options that are used to configure the new reference point.
ExceptionsException | Condition |
---|
ArgumentException |
The input point lies outside of Revit design limits.
-or-
options cannot be used to add a reference object to this DirectShape.
|
ArgumentNullException |
A non-optional argument was null
|
See Also