RebarUpdateCurvesDataSetHookOrientationAngle Method

Set the hook orientation angle at end. This information is set to the rebar after the API execution is finished successfully.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetHookOrientationAngle(
	int end,
	double angle
)

Parameters

end  Int32
The end of bar. Should be 0 for start or 1 for end.
angle  Double
The hook orientation angle at end.
Exceptions
ExceptionCondition
ArgumentOutOfRangeException Invalid end.
See Also