FamilySizeTableManagerImportSizeTable Method |
Imports a FamilySizeTable from a CSV file.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool ImportSizeTable(
Document document,
string filePath,
FamilySizeTableErrorInfo errorInfo
)
Public Function ImportSizeTable (
document As Document,
filePath As String,
errorInfo As FamilySizeTableErrorInfo
) As Boolean
public:
bool ImportSizeTable(
Document^ document,
String^ filePath,
FamilySizeTableErrorInfo^ errorInfo
)
member ImportSizeTable :
document : Document *
filePath : string *
errorInfo : FamilySizeTableErrorInfo -> bool
Parameters
- document Document
-
Family owned document or project document.
- filePath String
-
The CSV file path.
- errorInfo FamilySizeTableErrorInfo
-
An error object to be written to if errors occur.
Return Value
Boolean
True if successful, false otherwise.
Exceptions
See Also