ConnectorElementChangeHostReference(Reference, Edge) Method |
Changes the connector host reference to a new planar face and a new edge loop.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void ChangeHostReference(
Reference planarFace,
Edge edge
)
Public Sub ChangeHostReference (
planarFace As Reference,
edge As Edge
)
public:
void ChangeHostReference(
Reference^ planarFace,
Edge^ edge
)
member ChangeHostReference :
planarFace : Reference *
edge : Edge -> unit
Parameters
- planarFace Reference
-
The planar face to place the connector on.
- edge Edge
-
One of the edges in the edge loop that defines the new connector location on the planar face.
Exceptions
Remarks
The connector referenced by an edge loop has the fixed origin as defined by the edge loop.
See Also