FilteredWorksetCollectorToWorksetIds Method |
Returns the complete set of workset ids that pass the filter(s).
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ICollection<WorksetId> ToWorksetIds()
Public Function ToWorksetIds As ICollection(Of WorksetId)
public:
ICollection<WorksetId^>^ ToWorksetIds()
member ToWorksetIds : unit -> ICollection<WorksetId>
Return Value
ICollectionWorksetId
The complete set of workset ids.
ExceptionsException | Condition |
---|
InvalidOperationException |
The collector does not have a filter applied. Extraction or iteration of worksets is not permitted without a filter.
|
Remarks
This will reset the collector to the beginning and extract all worksets that pass the applied filter(s).
If you have an active iterator to this same collector it will be stopped by this call.
See Also