CurveLoopCreateViaThicken(CurveLoop, Double, XYZ) Method |
Creates a new closed curve loop by thickening the input open curve loop with respect to a given plane.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static CurveLoop CreateViaThicken(
CurveLoop curveLoop,
double thickness,
XYZ normal
)
Public Shared Function CreateViaThicken (
curveLoop As CurveLoop,
thickness As Double,
normal As XYZ
) As CurveLoop
public:
static CurveLoop^ CreateViaThicken(
CurveLoop^ curveLoop,
double thickness,
XYZ^ normal
)
static member CreateViaThicken :
curveLoop : CurveLoop *
thickness : float *
normal : XYZ -> CurveLoop
Parameters
- curveLoop CurveLoop
-
The input curve loop.
- thickness Double
-
The distance between the offset curves created on either side of the input curve.
- normal XYZ
-
The normal vector to the plane used for thickening.
Return Value
CurveLoop
The new curve loop.
Exceptions
Remarks
The new loop will be created via
offsets of the input curve loop (in the plane of the normal vector) with the endpoints
connected with lines.The original curve loop will be at the center of the new loop.
If the curve loop contains curves such as elliptical segments or splines, it is possible the offset creation will fail if
Revit will not be able to trim contiguous curves to meet one another. If the offset is successful, offsets of those curve types
will be created as HermiteSplines.
See Also