RebarBendData(RebarBarType, RebarHookType, RebarHookType, RebarStyle, RebarHookOrientation, RebarHookOrientation) Constructor |
Constructs a new RebarBendData using the bar type, hook types, style and orientation values.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic RebarBendData(
RebarBarType barType,
RebarHookType hookType0,
RebarHookType hookType1,
RebarStyle style,
RebarHookOrientation hookOrient0,
RebarHookOrientation hookOrient1
)
Public Sub New (
barType As RebarBarType,
hookType0 As RebarHookType,
hookType1 As RebarHookType,
style As RebarStyle,
hookOrient0 As RebarHookOrientation,
hookOrient1 As RebarHookOrientation
)
public:
RebarBendData(
RebarBarType^ barType,
RebarHookType^ hookType0,
RebarHookType^ hookType1,
RebarStyle style,
RebarHookOrientation hookOrient0,
RebarHookOrientation hookOrient1
)
new :
barType : RebarBarType *
hookType0 : RebarHookType *
hookType1 : RebarHookType *
style : RebarStyle *
hookOrient0 : RebarHookOrientation *
hookOrient1 : RebarHookOrientation -> RebarBendData
Parameters
- barType RebarBarType
-
- hookType0 RebarHookType
-
- hookType1 RebarHookType
-
- style RebarStyle
-
- hookOrient0 RebarHookOrientation
-
- hookOrient1 RebarHookOrientation
-
Exceptions
See Also