IExternalServiceGetDescription Method

Implement this method to return a description of the service.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
string GetDescription()

Return Value

String
Description of the service.
Remarks

The purpose of this string is to describe the external service in more details than just a short name alone could do. The intended use is to show the string to the end user in UI when UI is appropriate for the service.

Beside the requirement for it to be a non-empty string, there are no other general restrictions imposed by the External Services Framework.

See Also