RouteAnalysisSettingsIsLargeGeometryAllowed Method |
Returns if large geometry is allowed for path of travel creation or not.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsLargeGeometryAllowed()
Public Function IsLargeGeometryAllowed As Boolean
public:
bool IsLargeGeometryAllowed()
member IsLargeGeometryAllowed : unit -> bool
Return Value
Boolean
Remarks
The return value is based off the current setting for the AllowLargeGeometry Property as follows:
- If it is set to Prompt, then prompts the user to continue or not, if no ui is present, returns false.
- If it is set to DisAllaow, returns false.
- If it is set to Allow, returns true.
See Also