SolidSurfaceArea Property |
Returns the total surface area of this solid.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic double SurfaceArea { get; }
Public ReadOnly Property SurfaceArea As Double
Get
public:
property double SurfaceArea {
double get ();
}
member SurfaceArea : float with get
Return Value
DoubleThe real number equal to the total area of this solid.
Exceptions
Remarks
Calculates the surface area by adding together the areas of faces comprising this solid.
Will slightly underestimate if curved surfaces are present.
See Also