ReferencePointSetCoordinateSystem Method |
The position and orientation of the ReferencePoint.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetCoordinateSystem(
Transform coordinateSystem
)
Public Sub SetCoordinateSystem (
coordinateSystem As Transform
)
public:
void SetCoordinateSystem(
Transform^ coordinateSystem
)
member SetCoordinateSystem :
coordinateSystem : Transform -> unit
Parameters
- coordinateSystem Transform
-
ExceptionsException | Condition |
---|
ArgumentException |
Thrown when coordinateSystem does not specify an
orthonormal basis.
|
InvalidOperationException |
Thrown when CoordinateSystem is set while the Reference
property is not , and the ReferencePoint is unable to
move to the new location.
|
RemarksThe position of the point is given by
CoordinateSystem.Origin, and the orientation is specified
by the three unit vectors CoordinateSystem.BasisX, BasisY,
BasisZ. The basis vectors must be unit length and mutually
perpendicular.
Whenever the Reference property is not ,
changing the CoordinateSystem property has a compound
effect. First the point is moved to the specified
location. Then the point is moved to conform to its
Reference, by the shortest possible distance.
See Also