RebarConstraintGetTargetRebarHookBarEnd Method |
Returns 0 or 1 to indicate which end hook on the other Rebar Element to which this RebarConstraint is attached.
The RebarConstraint must be of RebarConstraintType 'ToOtherRebar,' and the TargetRebarConstraintType
must be 'HookBend'.
Rebar must be Shape Driven Rebar element.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic int GetTargetRebarHookBarEnd()
Public Function GetTargetRebarHookBarEnd As Integer
public:
int GetTargetRebarHookBarEnd()
member GetTargetRebarHookBarEnd : unit -> int
Return Value
Int32
ExceptionsException | Condition |
---|
InvalidOperationException |
RebarConstraint is no longer valid.
-or-
The RebarConstraint is not of RebarConstraintType 'ToOtherRebar'.
-or-
The RebarTargetConstraintType is not 'HookBend'
-or-
Constrained rebar isn't a shape driven rebar element.
|
Remarks
0 means start of the bar, and 1 indicates end of the bar.
See Also