ParameterClearValue Method |
Clears the parameter to its initial value.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
SyntaxPublic Function ClearValue As Boolean
public:
bool ClearValue()
member ClearValue : unit -> bool
Return Value
BooleanThe ClearValue method will return True if the parameter was successfully cleared to its initial value, otherwise false.
ExceptionsException | Condition |
---|
InvalidOperationException | The parameter is read-only, or the parameter is not a shared parameter,
or the shared parameter has HideWhenNoValue set to false. |
RemarksThis method will only succeed for Shared parameters that have their HideWhenNoValue property set to true.
See Also