ConduitSizeSettingsCreateConduitStandardTypeFromExisingStandardType Method |
Creates one conduit standard type with the new name and assign the conduit sizes to it from the existing standard type.
Namespace: Autodesk.Revit.DB.ElectricalAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool CreateConduitStandardTypeFromExisingStandardType(
Document pADoc,
string newStandardName,
string existingStandardName
)
Public Function CreateConduitStandardTypeFromExisingStandardType (
pADoc As Document,
newStandardName As String,
existingStandardName As String
) As Boolean
public:
bool CreateConduitStandardTypeFromExisingStandardType(
Document^ pADoc,
String^ newStandardName,
String^ existingStandardName
)
member CreateConduitStandardTypeFromExisingStandardType :
pADoc : Document *
newStandardName : string *
existingStandardName : string -> bool
Parameters
- pADoc Document
-
The document.
- newStandardName String
-
The new conduit standard name.
- existingStandardName String
-
The existing conduit standard name.
Return Value
Boolean
True if creating success; otherwise false.
Exceptions
See Also