RebarConstraintIsUsingClearBarSpacing Method |
Returns true if the RebarConstrainedHandle to target offset is the clear bar distance, false if the offset is measured between bar centers.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsUsingClearBarSpacing()
Public Function IsUsingClearBarSpacing As Boolean
public:
bool IsUsingClearBarSpacing()
member IsUsingClearBarSpacing : unit -> bool
Return Value
Boolean
Returns true if the RebarConstrainedHandle to target offset is the clear bar distance, false if the offset is measured between bar centers.
ExceptionsException | Condition |
---|
InvalidOperationException |
RebarConstraint is no longer valid.
-or-
The RebarConstraint is not of RebarConstraintType 'ToOtherRebar'.
-or-
The RebarConstraint constrain two Rebar ends.
-or-
The RebarTargetConstraintType is 'HookBend' or 'BarBend'.
|
Remarks
Throw exception if it's used on start/end handle to start/end handle constraint, and on constraints involving bar/hook bend handle.
See Also