RebarShapeDrivenAccessorTopFinishingTurns Property |
For a spiral, the number of finishing turns at the upper end of the spiral.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic int TopFinishingTurns { get; set; }
Public Property TopFinishingTurns As Integer
Get
Set
public:
property int TopFinishingTurns {
int get ();
void set (int value);
}
member TopFinishingTurns : int with get, set
Property Value
Int32
ExceptionsException | Condition |
---|
ArgumentOutOfRangeException |
When setting this property: turns must be between 0 and 100.
|
InvalidOperationException |
This RebarShapeDrivenAccessor is not an instance of a spiral shape.
-or-
This RebarShapeDrivenAccessor doesn't contain a valid rebar reference.
|
Remarks
Applies only to instances where RebarShape.Definition is of type
RebarShapeDefinitionByArc, and its Type property is equal to the value
RebarShapeDefinitionByArcType.Spiral.
See Also