EffectInstanceIsValid Method |
Tests whether the effect instance is valid for rendering.
Namespace: Autodesk.Revit.DB.DirectContext3DAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
SyntaxPublic Function IsValid As Boolean
member IsValid : unit -> bool
Return Value
Boolean
True if the effect instance is valid for rendering, false otherwise.
Remarks
The effect instances are internally associated with low-level graphics state and may become invalidated when
the state changes. Therefore, an application should test each effect instance for validity before using it when
submitting geometry. If the effect instance becomes invalid, the application should re-create it.
See Also