RibbonItemType Enumeration

An enumerated type listing all the toolbar item styles.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public enum RibbonItemType
Members
Member nameValueDescription
PushButton0A standard button with text and image.
PulldownButton1A button with a pull-down menu list.
SplitButton2A split button with a default button and a pull-down menu list.
ToggleButton3A standard button that can be added to RadioButtonGroup.
RadioButtonGroup4An item that contains a collection of RibbonToggleButton items.
ComboBoxMember5An item in the drop-down list of a ComboBox.
ComboBox6A selection control with a drop-down list that can be shown or hidden by clicking the arrow on the control.
TextBox7A text-based control that allows the user to enter text.
See Also