RebarConstraintSetToBindHandleWithTarget Method |
Sets the relationship between two RebarConstrainedHandles.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetToBindHandleWithTarget(
bool bindsHandleWithTarget
)
Public Sub SetToBindHandleWithTarget (
bindsHandleWithTarget As Boolean
)
public:
void SetToBindHandleWithTarget(
bool bindsHandleWithTarget
)
member SetToBindHandleWithTarget :
bindsHandleWithTarget : bool -> unit
Parameters
- bindsHandleWithTarget Boolean
-
False if only the constrained RebarConstrainedHandle follows the target. True if the constrained RebarConstrainedHandle and the target bar handle will be bound and move together.
ExceptionsException | Condition |
---|
InvalidOperationException |
RebarConstraint is no longer valid.
-or-
The RebarConstraint is not of RebarConstraintType 'ToOtherRebar'.
-or-
The RebarTargetConstraintType is 'HookBend' or 'BarBend'.
-or-
The RebarTargetConstraintType is 'OutOfPlaneExtent' and the rebar target layout is 'Number with Spacing'.
|
Remarks
Throws exception for any type of constraint other than 'ToOtherRebar' or if the RebarTargetConstraintType of the constraint is 'HookBend' or 'BarBend'.
Will also throw if the target Rebar has the 'Number with Spacing' layout rule and the RebarTargetConstraintType of the constraint is 'OutOfPlaneExtent'.
See Also