Supported geometric shapes of annotation leaders.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
SyntaxPublic Enumeration LeaderShape
public enum class LeaderShape
MembersMember name | Value | Description |
---|
Straight | 0 |
A single straight line between the end point and anchor point.
|
Kinked | 1 |
A kinked line with a shoulder defined by an elbow point.
|
Arc | 2 |
An arc between between the end point and anchor point.
In this shape the elbow point controls the arc's radius.
|
Remarks
Although the [!:Autodesk::Revit::DB::Leader] class supports
all available shapes, not all types of leaders may have the option to
change its shape. For example, leaders of text annotations can be of
any shape, while leaders of level lines are never curved.
See Also