BuiltInFailuresDisplacementElementFailures Class

Error messages related to the DisplacementElement.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBBuiltInFailuresDisplacementElementFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class DisplacementElementFailures

The BuiltInFailuresDisplacementElementFailures type exposes the following members.

Properties
 NameDescription
Public propertyStatic memberCannotCopyDisplacementSetIntoOtherDocument A Displacement Set can only be pasted into a view in the same document in which it was created.
Public propertyStatic memberCannotRemoveLastDisplacedElement A Displacement Set can only be pasted into a view in the same document in which it was created.
Public propertyStatic memberDetectedCycleInDisplacedElementParents Invalid parent relationship for a Displacement element. No cycles are allowed.
Public propertyStatic memberElementsAlreadyDisplacedInView You cannot copy a displacement set into a view if one or several of its elements already belong to another displacement set.
Top
See Also