DuctSystemType Enumeration |
An enumerated type listing all the possible duct system types for a connector object.
Namespace: Autodesk.Revit.DB.MechanicalAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum DuctSystemType
Public Enumeration DuctSystemType
public enum class DuctSystemType
MembersMember name | Value | Description |
---|
UndefinedSystemType | 0 |
Undefined system type.
|
SupplyAir | 1 |
Duct System Type is SupplyAir.
|
ReturnAir | 2 |
Duct System Type is ReturnAir.
|
ExhaustAir | 3 |
Duct System Type is ExhaustAir.
|
OtherAir | 4 |
Duct System Type is OtherAir.
|
Fitting | 28 |
Duct System Type is Fitting.
|
Global | 29 |
Duct System Type is Global.
|
See Also