DimensionSegmentTextPosition Property

The position of the dimension text's drag point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public XYZ TextPosition { get; set; }

Property Value

XYZ
Exceptions
ExceptionCondition
ApplicationException Thrown when the dimension text is unavailable.
InvalidOperationException Thrown when:
  • The dimension text is a SpotElevation
  • When using equality formula.
  • When dimension style is ordinate.
.
Remarks

This property is not applicable to all dimensions. For example, it is not available for spot dimensions, dimensions using equality formula, and when dimension style is ordinate.

If the position is not applicable, this property returns NULL and will not allow setting a value.

Example
C#
      // Get the current text XYZ position
XYZ currentTextPosition = currentSegment.TextPosition;
// Calculate a new XYZ position by transforming the current text position
XYZ newTextPosition = Transform.CreateTranslation(new XYZ(0, 1, 0)).OfPoint(currentTextPosition);
// Set the new text position for the segment's text
currentSegment.TextPosition = newTextPosition;
See Also