RebarConstraintFlipHandleOverTarget Method |
Flips the RebarConstrainedHandle to the other side of the target bar handle, maintaining the distance in absolute value.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void FlipHandleOverTarget()
Public Sub FlipHandleOverTarget
public:
void FlipHandleOverTarget()
member FlipHandleOverTarget : unit -> unit
ExceptionsException | Condition |
---|
InvalidOperationException |
RebarConstraint is no longer valid.
-or-
The RebarConstraint is not of RebarConstraintType 'ToOtherRebar'.
-or-
The RebarTargetConstraintType is 'HookBend' or 'BarBend'.
|
Remarks
Throw exception if constraint type is not 'ToOtherRebar', or for constraints involving bar/hook bend handle.
See Also