SelectionPickBox(PickBoxStyle) Method |
Invokes a general purpose two-click editor that lets the user to specify a rectangular area on the screen.
Namespace: Autodesk.Revit.UI.SelectionAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic PickedBox PickBox(
PickBoxStyle style
)
Public Function PickBox (
style As PickBoxStyle
) As PickedBox
public:
PickedBox^ PickBox(
PickBoxStyle style
)
member PickBox :
style : PickBoxStyle -> PickedBox
Parameters
- style PickBoxStyle
- Specifies the value that controls the style of the pick box.
Return Value
PickedBoxThe picked box that contains two XYZ points.
ExceptionsException | Condition |
---|
ArgumentOutOfRangeException | Thrown when the style is not a recognized value. |
OperationCanceledException | Thrown when the Revit user cancelled this operation.
Thrown when the Revit user tried to switch the active view, close the active document or Revit application when responding to this mode.
|
Remarks
The method starts an editor and returns when it finishes. Returns a PickedBox that contains two XYZ points.
See Also