TaskDialogMainContent Property |
MainContent is the smaller text that appears just below the main instructions.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic string MainContent { get; set; }
Public Property MainContent As String
Get
Set
public:
property String^ MainContent {
String^ get ();
void set (String^ value);
}
member MainContent : string with get, set
Property Value
String
Remarks
The Main Content is optional. It should be used to give further explanation to the user, such as how to correct the problem or work around the situation.
It displays in a smaller black font below the main instructions. Follow these guidelines:
- Text should be clear and jargon free.
- Main content should not simply restate the main instructions in a different way, they should contain additional information
that builds upon or reinforces the main instructions.
- Main content should be written in sentence format (normal capitalization and punctuation).
- Address the user directly as "you" when needed.
See Also