TransactWithCentralOptionsSetLockCallback Method

Sets or resets a callback object that would allow an external application to change Revit's default behavior of endlessly waiting and repeatedly trying to lock a central model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetLockCallback(
	ICentralLockedCallback lockCallback
)

Parameters

lockCallback  ICentralLockedCallback
 
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
See Also