MechanicalSystemBaseEquipmentConnector Property

The connector within the base equipment which is used to connect with the system.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public Connector BaseEquipmentConnector { get; set; }

Property Value

Connector
Exceptions
ExceptionCondition
ArgumentException Thrown when assigning a connector which is used in a system, or when the connector's owner is not of type 'mechanical equipment'.
InvalidOperationException Thrown when the set operation failed.
Remarks
Assigning to the base equipment connector will disconnect the base equipment from the system.
See Also