The outward-facing normal vector of the exterior side face at the starting point of the wall.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic XYZ Orientation { get; }
Public ReadOnly Property Orientation As XYZ
Get
public:
property XYZ^ Orientation {
XYZ^ get ();
}
member Orientation : XYZ with get
Property Value
XYZ
Remarks
For curtain walls and stacked walls, the wall itself doesn't have exterior and interior side faces.
Therefore, in both cases, the wall's orientation is not changed when it is flipped. However, flipping curtain walls or stacked walls will change the orientations of their sub-walls.
In the case of curtain walls, sub-walls are present when a curtain panel type is changed to a wall.
See Also