DirectShapeLibraryAddDefinition(String, IListGeometryObject) Method |
Add a definition to be reused by instances. A definition is a collection of geometry objects.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void AddDefinition(
string id,
IList<GeometryObject> GNodes
)
Public Sub AddDefinition (
id As String,
GNodes As IList(Of GeometryObject)
)
public:
void AddDefinition(
String^ id,
IList<GeometryObject^>^ GNodes
)
member AddDefinition :
id : string *
GNodes : IList<GeometryObject> -> unit
Parameters
- id String
-
ID of the definition to be added. Must be unique.
- GNodes IListGeometryObject
-
Definition as a list of Geometry objects
Exceptions
See Also