TemporaryGraphicsCommandData Class

The context data that can be provided to OnClick(TemporaryGraphicsCommandData).
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.UITemporaryGraphicsCommandData

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class TemporaryGraphicsCommandData : IExternalData, 
	IDisposable

The TemporaryGraphicsCommandData type exposes the following members.

Properties
 NameDescription
Public propertyDocument The document.
Public propertyIndex The unique index of the temporary graphics object managed by TemporaryGraphicsManager.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the TemporaryGraphicsCommandData
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also