ExportPDFSettingsCreate Method |
Returns an new created ExportPDFSettings element in the document with specified settings.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static ExportPDFSettings Create(
Document document,
string name,
PDFExportOptions options
)
Public Shared Function Create (
document As Document,
name As String,
options As PDFExportOptions
) As ExportPDFSettings
public:
static ExportPDFSettings^ Create(
Document^ document,
String^ name,
PDFExportOptions^ options
)
static member Create :
document : Document *
name : string *
options : PDFExportOptions -> ExportPDFSettings
Parameters
- document Document
-
Document where the settings will be created.
- name String
-
Name to the settings.
- options PDFExportOptions
-
The options to be set.
Return Value
ExportPDFSettings
New instance of ExportPDFSettings just created in the document.
ExceptionsException | Condition |
---|
ArgumentException |
name is an empty string or contains only whitespace.
-or-
name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~".
-or-
Setting name.
|
ArgumentNullException |
A non-optional argument was null
|
ModificationForbiddenException |
The document is in failure mode: an operation has failed,
and Revit requires the user to either cancel the operation
or fix the problem (usually by deleting certain elements).
-or-
The document is being loaded, or is in the midst of another
sensitive process.
|
ModificationOutsideTransactionException |
The document has no open transaction.
|
See Also