ViewCropRegionShapeManagerSplitRegionHorizontally Method |
Splits horizontally one region in split crop.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SplitRegionHorizontally(
int regionIndex,
double leftPart,
double rightPart
)
Public Sub SplitRegionHorizontally (
regionIndex As Integer,
leftPart As Double,
rightPart As Double
)
public:
void SplitRegionHorizontally(
int regionIndex,
double leftPart,
double rightPart
)
member SplitRegionHorizontally :
regionIndex : int *
leftPart : float *
rightPart : float -> unit
Parameters
- regionIndex Int32
-
Index of region to be split horizontally (numbering starts with 0).
- leftPart Double
-
Relative portion of the original region to become the new left region (0 to 1).
- rightPart Double
-
Relative portion of the original region to become the new right region (0 to 1).
ExceptionsException | Condition |
---|
ArgumentException |
The provided view region proportions are not valid.
-or-
The provided region index is invalid.
|
InvalidOperationException |
The crop of the associated view is not permitted to have multiple regions.
-or-
The view has non-rectangular crop shape set.
-or-
The view crop is already split vertically.
|
Remarks
This function splits the crop into two regions: one occupying the left quarter of the crop, and the other the right quarter of the crop.
See Also